FOLLOW US

Blog

WordPress 3.6 making your SlideDecks cry? No problem!

By 13 Comments
14 Flares 14 Flares ×

Please don't cry! SlideDeck 2.3.3 will make it all better.

As happens from time-to-time, we’ve discovered that the WordPress 3.6 release causes issues with SlideDeck 2 – but fear not! We have you covered with the latest plugin update that we’ve just released.

There, there – SlideDeck 2.3.3 makes it all better

We’ve just pushed out a hotfix for SlideDeck that addresses the issue caused by upgrading to WordPress 3.6. If you have a valid license, all you have to do is update to the latest version from your Plugins menu – easy!

If your license is expired, you’ll need to renew it before you can grab the update – but don’t worry, it’s also easy! Renew now to instantly resume access to critical plugin updates like this one. Remember, Personal users get 25% off the regular price, and Professional and Developer tier users get 50% off when you renew!

Renew Now

Why do I need to renew?

Got it. What was the problem?

Basically, WordPress changed the way they were including jQuery, the javascript library that SlideDeck 2 uses not only for making the sliders work, but also a lot of the admin menus and interactions. To paraphrase the immortal words of Mr. Mackey, “That’s bad, mmkay?”. From what we’re seeing, regular SlideDecks are unaffected, but SlideDecks embedded using iFrames stop working once you update to WP3.6. In both cases, the admin screens of SlideDeck likely won’t function correctly after you update WordPress.

Happy Friday, everyone! And do us a favor – spread the word, would you?

Leave a Reply

Comments (13) Responses

  1.  

    Michael Gibbs

    We’ve got a Developer license but can’t the latest update to install. It is like the download from Amazon S3 is failing or timing out.

    Can you take a look and ensure that there are no problems with the latest update you pushed out?

    •  

      Jamie

      Hi Michael,
      It sounds like this is most likely a temporary issue. Also, I have seen file permission errors cause the update process to halt in the past. If you can’t get it resolved with a manual (FTP) update or a few more retries, then just open a support ticket and one of us will do our best to help out.

  2.  

    NLP Life Coach

    Hey Jason, or whoever is reading this and can advise me!

    I have 2 sites and run WordPress 3.6.1 on both sites. I have SlideDeck version 1.3.72 on one site and version 1.4.1 on the other. When my developer advised me to use SlideDeck and helped me implement it into my sites, he designed their looks so that they’d exactly fit into the looks of my sites. When I asked him about updating the SlideDeck plugins, he said don’t do it, but didn’t explain why – most likely because he didn’t wanna burden me with too many technicalities which he knew would only confuse me at the time. So this is why my versions of SlideDeck are so old. My question: what would happen if I updated the SlideDeck plugins on both sites? Would they run with WP 3.6.1? Would there be a disaster? Should I better not touch them? What would happen? Please advise. I’ll be very grateful.

    •  

      Jason

      Hi there – SlideDeck 1.4.8 and all preceding versions has been retired, so we no longer support it. I can’t guarantee what would happen if you updated your plugin to version 1.4.8, since I don’t know what customizations were made to your particular copy. Sorry I can’t be more specific!

  3.  

    Jenne

    So not impressed. Everything on the site says it works with Chrome. I just installed and check out every avenue to make sure the install is correct with no other plugins on and such. It will not work in Chrome at all. Works fine in Firefox. Brand new install it should work.

    •  

      Jason

      Hi Jenne, thanks for the heads-up. We’ve not heard of any issues with Chrome – would you mind shooting us a note via our contact page, with some more info as to your specific setup, so we can investigate?

  4.  

    Andres

    Just install jQuery Updater plugin. This fix my problem. I hope Jason do not delete this post.

    Best regards,

    Andres.

  5.  

    Seth

    Unfortunately this fix did not work, and jQuery still fails to load. Check out http://gradmap.com and inspect the page to see the errors.

    Any help would be immensely appreciated!!

  6.  

    Cathy Finn-Derecki

    Our slidedeck won’t behave in iframes. I upgraded to 3.6 then did your upgrade and still it won’t load in the admin or on the frontend. I’ve had to switch to not loading in iframes This is kind of a big problem.

    •  

      Jason

      Hi Cathy – please feel free to submit a support ticket, and we’ll do our best to help you out!

  7.  

    David Benedetti

    I’m sorry, but you’re forcing us to renew our license in order to receive a BUG FIX update?

    There is a blatant falsehood in the FAQ attached to this page:

    Will my SlideDecks stop working once my license expires?
    Absolutely not! Again – we will never touch your SlideDecks when your license expires.

    Unfortunately, that is incorrect, as all of the slidedecks on my sites, as well as client sites, are currently broken, and since my developer’s license expired a few days ago, I only have 3 options, none of which are attractive: 1. Continue to let DT hold me over a barrel and renew to get the update. 2. Let my sites remain broken or 3. Find an alternate slider solution for my network of sites.

    I’m asking DT to do the right thing and release this bug fix update for free, without need for a current license, as this isn’t an upgrade or anything beyond fixing bugs in the slidedeck plugin itself.

    •  

      Jason

      Hi David

      This issue actually occurred due to a change that WordPress 3.6 introduced – they changed the method they were using to include jQuery, which is a critical library not just for SlideDeck, but many other plugins. This is less a case of a mistake in our code, and more an unfortunate reality of the shifting nature of the WordPress platform – it’s something we have very little control over. The fact that keeping SlideDeck functional requires continuous updates and maintenance is exactly the reason why we ask our users to maintain a valid license with us. This is an ongoing cost to us as a business, so the right thing is to contribute to the cost of development if you’re getting value from the plugin – we even absorb some of this cost by offering up to 50% off for a renewal.

      With regards to our FAQ, it’s accurate – we don’t touch your SlideDecks after your license expires, and usually, they’ll continue functioning for a while. This happens to be an unlucky update from WordPress that caused SlideDeck to stop working in some cases, and this is why we dropped everything to fix it ASAP.

14 Flares Twitter 5 Facebook 8 Google+ 1 14 Flares ×